Client Dashboard maintenance
Scheduled for March 05, 2024 at 6:12 PM – 7:17 PM
Affects
Core Services
Under maintenance from 6:12 PM to 7:17 PM
Client Portal
Under maintenance from 6:12 PM to 7:17 PM
Completed
March 05, 2024 at 7:17 PMCompleted
March 05, 2024 at 7:17 PMMaintenance has been completed.
In progress
March 05, 2024 at 6:12 PMIn progress
March 05, 2024 at 6:12 PMWe are currently performing a scheduled maintenance on our client dashboard.
Estimated duration is 1 hour.
For assistance please email support@cloudfanatic.net